View Issue Details

IDProjectCategoryView StatusLast Update
0001258Database Comparer VCL[All Projects] Generalpublic2019-04-18 19:44
ReportershirokovAssigned Tobarry 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0001258: FB 3 database and script extracting errors
DescriptionWhen you extract the PROCEDURE_FILIAL_ZERO stored procedure from the DATABASE_TEST.FDB, the following error occurs:
Procedure PROCEDURE_FILIAL_ZERO: Invalid factor in expression (POSITION)
Script: Line:19 Pos:19

The script contains the following code:
if (position('TABLE_', vTabela) > 0) then

Also, when extracting from the "Script_Comparer.Sql" script, the following error occurs:
Invalid char in source text: "{".
Script: C:\Progects\DbComparer\bug\DB\Script_Comparer.Sql Line:1 Pos:2

In fact, this script doesn't include the "{" symbol at Line:1 Pos:2
Steps To ReproduceThe demo project, DB, and script are attached.

There is a video that describes the problem:
https://mega.nz/#!l3Y3ATxR!xRfhvdyrsOkvWNtob03sIQxY5oQHN9YfDJ9DCovpPcg

The demo uses IBDAC and Delphi 10.2 Tokyo. But in fact, the problem can be reproduced with any database connection.
TagsNo tags attached.

Activities

shirokov

2018-03-13 22:05

administrator  

Demo DataBaseComparer.zip (81,019 bytes)

barry

2018-06-01 05:22

administrator   ~0003740

Скрипт в каком-то полу-RTF формате, конечно будет Invalid char in source text: "{".

shirokov

2018-06-19 19:21

administrator   ~0003836

The problem is not resolved in build 1673.
See the screenshot http://www.clevercomponents.com/dev/dbc/support/bugtracker-issue1258-image001.png
FB 2.1.7

shirokov

2019-03-20 12:02

administrator   ~0004017

The problem with POSITION keyword is because it is used both for TRIGGER Header and POSITION internal function. You only handle the trigger but not the internal function and as a result you produce parsing error.

Issue History

Date Modified Username Field Change
2018-03-13 22:05 shirokov New Issue
2018-03-13 22:05 shirokov File Added: Demo DataBaseComparer.zip
2018-03-29 18:38 shirokov Assigned To => barry
2018-03-29 18:38 shirokov Status new => assigned
2018-06-01 05:22 barry Note Added: 0003740
2018-06-01 05:23 barry Status assigned => resolved
2018-06-01 05:23 barry Resolution open => no change required
2018-06-19 19:21 shirokov Status resolved => feedback
2018-06-19 19:21 shirokov Resolution no change required => reopened
2018-06-19 19:21 shirokov Note Added: 0003836
2019-03-20 12:02 shirokov Note Added: 0004017
2019-03-20 12:02 shirokov Status feedback => assigned
2019-04-11 17:15 barry Status assigned => resolved
2019-04-18 19:44 barry Status resolved => closed