View Issue Details

IDProjectCategoryView StatusLast Update
0000996Database Comparer[All Projects] Generalpublic2019-04-18 19:46
ReportershirokovAssigned Tobarry 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.1663 
Summary0000996: Errors when comparing generators with IBExpert syntax, Firebird 3.0
Description1. There are errors when comparing generator:
CREATE GENERATOR GEN_CAIXA START WITH 0 INCREMENT BY 1;
Giving the error "Missing: <TERM> (<Ident>: START)"

2. Procedure PROCEDURE_FILIAL_ZERO: Invalid factor in expression (POSITION)
However this Position command is valid I do not understand the problem it seems that DbComparer does not recognize the command "Position"
The Stranger is that the "Position" command has existed in Firebird since version 2.1
Steps To ReproduceCompare the provided database and SQL script
TagsNo tags attached.

Activities

shirokov

2016-12-14 22:37

administrator  

DBComparerDemoIBDAC.rar (540,486 bytes)

barry

2016-12-15 11:38

administrator   ~0002501

v.6.4.0.1663

barry

2017-05-15 16:37

administrator   ~0002713

test message from tracker

Issue History

Date Modified Username Field Change
2016-12-14 22:37 shirokov New Issue
2016-12-14 22:37 shirokov File Added: DBComparerDemoIBDAC.rar
2016-12-15 11:38 barry Note Added: 0002501
2016-12-15 11:38 barry Status new => resolved
2016-12-15 11:38 barry Fixed in Version => 6.4.0.1663
2016-12-15 11:38 barry Resolution open => fixed
2016-12-15 11:38 barry Assigned To => barry
2017-05-15 16:37 barry Note Added: 0002713
2019-04-18 19:46 barry Status resolved => closed