View Issue Details

IDProjectCategoryView StatusLast Update
0001455Database Comparer VCL[All Projects] Generalpublic2019-04-18 19:43
ReportershirokovAssigned Tobarry 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version[Database Comparer] 7.0.0.1670 
Target Version[Database Comparer] 7.0.0.1670Fixed in Version[Database Comparer] 7.0.0.1680 
Summary0001455: CREATE GLOBAL TEMPORARY TABLE parsing error
DescriptionIBScript parser causes the "unknown CREATE statement"error at the following script line:
CREATE GLOBAL TEMPORARY TABLE

The problem is reproduced when running DBComparerDemoIBX on Delphi XE7.

The SQLServerVersion was explicitly set to st_Firebird_30 in this demo.

The standalone DBComparer Tool works correctly.

Both, master and target are attached.
TagsNo tags attached.

Activities

shirokov

2018-08-09 18:45

administrator  

FB3Error.ZIP (73,733 bytes)

barry

2018-08-10 12:39

administrator   ~0003887

На билде 1673 (DBComparer) со скриптом вроде как все нормально.
Может в демке там что-то не так с версиями.

Issue History

Date Modified Username Field Change
2018-08-09 18:45 shirokov New Issue
2018-08-09 18:45 shirokov Status new => assigned
2018-08-09 18:45 shirokov Assigned To => barry
2018-08-09 18:45 shirokov File Added: FB3Error.ZIP
2018-08-10 12:39 barry Note Added: 0003887
2018-09-26 12:22 barry Status assigned => feedback
2019-04-11 17:57 barry Status feedback => resolved
2019-04-11 17:57 barry Resolution open => fixed
2019-04-18 12:00 barry Fixed in Version => 7.0.0.1680
2019-04-18 12:00 barry Description Updated View Revisions
2019-04-18 19:43 barry Status resolved => closed