View Issue Details

IDProjectCategoryView StatusLast Update
0001545Database Comparer VCL[All Projects] Generalpublic2019-07-29 17:38
ReportershirokovAssigned Tobarry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version[Database Comparer] 7.1.0.1686 
Target Version[Database Comparer] 7.1.0.1686Fixed in Version 
Summary0001545: Problems with updating cross-linked stored procedures.
DescriptionIn Procedure "PKTOLISTE" (proc1, see attached file) there is a call to another procedure called "PktoListeSub" (proc2) via execute procedure.
The generated update script fails on dropping proc2 because proc1 has dependency to proc2.
In version 6.4 the update script has a statement to empty the body of proc1 to resolve dependency .
In versoin 7.1. that stetement is missing.
See attached SQL scripts.

The problem is reproduced in both VCL and standalone edition, 7.1.0.1686.
Problem does not occure with version 6.4.

The master and target databases are attached, as well.
Master has only one procedure. Target has two procs.

DBComparer-Tool Log:
Updating target database...
Charset: NONE
Connect: "d:\db\dbcomparer\targetnew.fdb"
Dialect: 1. DBCharSet: NONE.
< Exec SQL >: PKTOLISTESUB: drop
Error: dbcDataMod_1.DBCConnection:
This operation is not defined for system tables.Unsuccessful metadata update.
Cannot delete.
PROCEDURE PKTOLISTESUB.
There are 1 dependencies.

< Exec SQL >: PKTOLISTE: alter
< Script executed: 1 errors... >
TagsNo tags attached.

Activities

shirokov

2019-07-26 10:50

administrator  

cros-linked-procs.zip (51,854 bytes)

barry

2019-07-29 17:38

administrator   ~0004161

1688

Issue History

Date Modified Username Field Change
2019-07-26 10:50 shirokov New Issue
2019-07-26 10:50 shirokov Status new => assigned
2019-07-26 10:50 shirokov Assigned To => barry
2019-07-26 10:50 shirokov File Added: cros-linked-procs.zip
2019-07-29 17:38 barry Status assigned => resolved
2019-07-29 17:38 barry Resolution open => fixed
2019-07-29 17:38 barry Note Added: 0004161